0 votes
5.6k views
by (1.1k points)

I have just changed the path in wp-config.php file then I got this error. I'm totally unknown what I do know. Please help..

Following error windows appears (see screengrab)

wp-load.php error
 

Warning: require_once(/srv/users/serverpilot/apps/example/public/wp-config.php): failed to open stream: Permission denied in /srv/users/serverpilot/apps/example/public/wp-load.php on line 37

Fatal error: require_once(): Failed opening required '/srv/users/serverpilot/apps/example/public/wp-config.php' (include_path='.:/opt/sp/php7.0/lib/php') in /srv/users/serverpilot/apps/example/public/wp-load.php on line 37

1 Answer

0 votes
by (9.4k points)

The error message might big, but the solution is so tiny.smiley This error is an outcome of degraded file permission level. Due to the 640 level permission to wp-config.php, the WordPress themes, plugins fails to change/save. Just change the file permission of wp-config file to 644. That's it. Done..! yes

How to do that,

  1. You can view file permission level via cPanel, FTP, FileZilla or CyberDuck
  2. Change the file permission to 644 for wp-config.php
  3. Done..!
File Permission Level
File Permission in FileZilla
by (100 points)

Answer by luckybhumkar is very helpfull. It worked for me. But I changed file permissions of my wp-config.php.  Thank u so much.

by (9.4k points)
Thank-you Soundarya   :-)
Welcome to DoubtSolver Q&A, where you can ask doubts and receive solutions from other members of the community.

Categories

...